86 Bronco II Automatic Jerks When Put In Drive

Ask technical questions about your Ford Bronco II here. Technical write-ups on your axle swaps, engine swaps, chop tops, etc. are encouraged.
mknulph
Posts: 3
Joined: Wed Nov 02, 2016 11:07 am
Location: California

86 Bronco II Automatic Jerks When Put In Drive

Postby mknulph » Wed Nov 02, 2016 11:12 am

Hi -

My 16yo son just bought a 1986 Bronco II 2.9 Automatic 4WD with 67k miles on it. When he puts the Bronco into D, N, R, P it jerks or lurches hard. Anyone have this issue and what did you do to fix it?

The previous owner just change the fuel filter, ignition coil, and ignition module.

Thanks for the help!
Melissa

User avatar
Phillippi
Posts: 1137
Joined: Mon Apr 19, 2004 9:11 pm
Location: UTAH
Contact:

Re: 86 Bronco II Automatic Jerks When Put In Drive

Postby Phillippi » Wed Nov 02, 2016 6:59 pm

It lurches with the foot on the brake? Like the brakes are bad or it lurches with so much power that it moves even with the brakes applied.? Is the idle way too high (higher than about 750RPM)?

mknulph
Posts: 3
Joined: Wed Nov 02, 2016 11:07 am
Location: California

Re: 86 Bronco II Automatic Jerks When Put In Drive

Postby mknulph » Mon Nov 07, 2016 1:03 pm

It lurches with so much power that it moves the Bronco even with the foot on the brake.

Idle is normal

mknulph
Posts: 3
Joined: Wed Nov 02, 2016 11:07 am
Location: California

Re: 86 Bronco II Automatic Jerks When Put In Drive

Postby mknulph » Mon Nov 07, 2016 1:10 pm

It also doesn't matter if the engine is cold or not.

User avatar
Phillippi
Posts: 1137
Joined: Mon Apr 19, 2004 9:11 pm
Location: UTAH
Contact:

Re: 86 Bronco II Automatic Jerks When Put In Drive

Postby Phillippi » Mon Nov 07, 2016 9:49 pm

Here is a long shot, but is it in 4lo?


Return to “Bronco Tech”

Who is online

Users browsing this forum: No registered users and 2 guests