88 bronco 2

Ask technical questions about your Ford Bronco II here. Technical write-ups on your axle swaps, engine swaps, chop tops, etc. are encouraged.
Jwj18
Posts: 2
Joined: Mon Apr 13, 2015 2:54 pm
Location: Aiken sc

88 bronco 2

Postby Jwj18 » Wed Apr 15, 2015 12:52 pm

Ok so to get started my 88 bronco 2 started to get hot and loose power and shut off so i replaced a couple bad hoses and the thermostat and it was running cooler but it still losed power after driving it for about 30 minutes it would start to run rough then when u would give it gas it would cut out and its getting fuel so i need help on figuring out what it is

User avatar
tekatlarge
Posts: 959
Joined: Tue Jan 17, 2006 8:54 am
Location: Kent, Worshington

Re: 88 bronco 2

Postby tekatlarge » Fri Apr 17, 2015 7:03 am

Sounds to me like you have a blown head gasket or cracked head. If you overheat a 2.9 it is almost certain you will crack a head.
The Tek @ Large
Kent,Worshington
I was borne under a rock. So what's your excuse?

duchie12
Posts: 1
Joined: Fri Apr 03, 2015 8:08 am

Re: 88 bronco 2

Postby duchie12 » Thu Apr 23, 2015 12:16 pm

The shutting off is the ignition module on the back of the dist. ford has had that problem with the tfi ( thick film ignition). they will run until they get hot then shut off. You can do the ignition module relocate or just replace the module. They tend to run for shorter and shorter times as they age. Ive had the fun times also with the module. Drive thirty minutes then it would shut off. you can test it by get some ice and run it until it shuts off then melt hands full of ice on the module until cool and see if it starts.

Jwj18
Posts: 2
Joined: Mon Apr 13, 2015 2:54 pm
Location: Aiken sc

Re: 88 bronco 2

Postby Jwj18 » Thu Apr 23, 2015 6:17 pm

Instead of replacing the module i replaced the whole distributor and now the timing is off


Return to “Bronco Tech”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest