Please help with my 86 Bronco II

Ask technical questions about your Ford Bronco II here. Technical write-ups on your axle swaps, engine swaps, chop tops, etc. are encouraged.
Richard85
Posts: 10
Joined: Fri Jul 25, 2014 10:12 am
Location: Odessa, Texas

Please help with my 86 Bronco II

Postby Richard85 » Thu Aug 28, 2014 2:17 pm

Ok I have been reading all kinds of stuff online about this problem but I have not found any solutions to it yet..

I've got a 1986 Ford Bronco II with the 2.9 v6 and it keeps shutting off on me after driving it for a while.. Let me try to explain what it's doing and then I'll list what I've replaced.

Ok now it'll start up fine, I can take off in it and drive for about 9 or 10 miles then it'll start sputtering and bucking real bad like it's running outta gas (gas gauge works and it's got 1/4 tank) then it'll just die. After letting it sit for a few minutes, I can fire it back up but now it runs like crap. I can take off in it but now I can only go about 1 or 2 miles before it starts doing the same thing (doesn't matter if it's hot or cold outside)..... I pop the hood and check for fuel pressure and I've got gas spraying out of the Schrader valve and I've got spark from the coil pack and the distributor.. The Fuel Pump Relay and the EEC Relay feel like they're hot when I touch them but I'm sure that they would be anyways since it's hot under the hood and the Relays are under currency or whatever!!

Now to what I've replaced
ECM (August 26th)
Coil Pack
Spark Plug Wires
Spark Plugs
High Pressure Pump
Fuel Pump Sending Unit in rear tank (with new pump)
Starter (cause the Starter was feeling hot to the touch when it'd die)

I don't want to keep dumping money into this dang thing cause I am currently not working due to no transportation.. I'm wondering if it's worth fixing or if I should just sell it and let someone else deal with the headaches.. Please Please Please if anyone sees this and knows what it IS let me know....

Thanks in advance,
Richard

User avatar
tekatlarge
Posts: 950
Joined: Tue Jan 17, 2006 8:54 am
Location: Kent, Worshington

Re: Please help with my 86 Bronco II

Postby tekatlarge » Thu Aug 28, 2014 9:13 pm

Richard,
You probably have a Bad TFI. That is the little gray thing on the side of the Distributor that the harness plugs into. They are a typical to fail like that. Autozone or your local auto parts will have it. There is 1 other item that fails the same way and that is the electronic module inside the distributor. That item fails less than the TFI.

One note when replacing the TFI you will need a 5.5mm socket. Or was that 6.5 Maybe someone will jump in but that is where your problem is.
The Tek @ Large
Kent,Worshington
I was borne under a rock. So what's your excuse?

kirkland2887
Posts: 86
Joined: Sun Jan 29, 2012 6:00 pm
Location: Albion, Idaho

Re: Please help with my 86 Bronco II

Postby kirkland2887 » Sun Aug 31, 2014 9:06 am

another thing to check is the plate the rotor mounts to. sounds just like what mine was doing. where the plate mounts to shaft rusted out. where i am i can get distributor and tfi as unit cheaper than just tfi. how stupid is that.

User avatar
2813josh
Posts: 5
Joined: Thu Nov 06, 2014 6:39 pm
Location: Mascotte, Florida
Contact:

Re: Please help with my 86 Bronco II

Postby 2813josh » Thu Nov 06, 2014 6:56 pm

I agree that it sounds like TFI. pretty common. But could also be injectors, resistance goes up with temp.

Lance Skene
Posts: 130
Joined: Fri Dec 27, 2013 8:06 am
Location: Calgary Alberta

Re: Please help with my 86 Bronco II

Postby Lance Skene » Tue Dec 16, 2014 10:37 am

Ok Im late to the party again but.... that sounds very much like the old non vented gas cap problem... somebody puts on a new locking gas cap but didn't get the vented one, or the vent in the original cap is plugged. When I bought my first B2 it did exactly the same thing, it had a locking cap that needed a little extra effort to push it on, but that also sealed off the vent which created a vacumn in the tank.
'80 Bronco 351M
'85 BII 2.8/Duraspark
'89 F150 302 Supercab


Return to “Bronco Tech”

Who is online

Users browsing this forum: No registered users and 1 guest