Fuel Gauge problems 86 Bronco II

Ask technical questions about your Ford Bronco II here. Technical write-ups on your axle swaps, engine swaps, chop tops, etc. are encouraged.
Posts: 10
Joined: Fri Jul 25, 2014 10:12 am
Location: Odessa, Texas

Fuel Gauge problems 86 Bronco II

Postby Richard85 » Thu Jul 31, 2014 5:05 pm

I put a new Sending Unit in my 86 Bronco II and my fuel gauge still doesn't work. Anyone know why this would be happening?

User avatar
Posts: 951
Joined: Tue Jan 17, 2006 8:54 am
Location: Kent, Worshington

Re: Fuel Gauge problems 86 Bronco II

Postby tekatlarge » Thu Jul 31, 2014 5:54 pm

I am going to take a stab at that. If you are sure the tank element is good there could be at least 4 possible things to make the dash gauge not register.

1 the gauge in the dash may be bad.

2 The tiny voltage regulator on the back of the dash could be bad. It is a little can about an inch long 3/8 wide attached to the back of the dash panel. that little bugger supplies regulated voltage to your dash instruments. You never said if any of the other instruments like temp or others that are not working. When that regulator goes so does most of your dash instruments go Nuts either No reading or high reading or very low readings.

3 Never overlook this obvious. are all the fuses good in your fuse block. I think the fuse is identified as instruments. Check it out. This should have been #1 but at least I mentioned it.

4 Lastly check all wires and connectors from the tank to the gauge.

If that doesn't find your problem, let me know and I will look in the secret archives and get ya some tests to use.

The Tek @ Large
I was borne under a rock. So what's your excuse?

Return to “Bronco Tech”

Who is online

Users browsing this forum: No registered users and 1 guest