87 Bronco II 2.9L Shuts off while driving

Ask technical questions about your Ford Bronco II here. Technical write-ups on your axle swaps, engine swaps, chop tops, etc. are encouraged.
Post Reply
rlee728
Posts: 2
Joined: Sat Mar 20, 2010 1:26 pm
Location: Kansas City, MO

87 Bronco II 2.9L Shuts off while driving

Post by rlee728 » Sat Mar 20, 2010 1:38 pm

I have an 87 Bronco II that will run for a while...15 to 20 minutes and then shut off. The problem has grown from shutting off randomly while driving but always starting right up again, to shutting off and not starting again for about an hour. When I go to start it up, it hestitates as if the battery has a low charge. I have a new battery. I replaced the Coil, the Distributor Module, even the Distributor...but it still shuts off. I blew a head gasket in the original motor and recently replaced the motor. The guy that put it in thought he fixed the problem by cleaning the coil. I drove it for about 800 miles with no problem. Then it started doing the cut-off thing again. Any ideas?

Reggie

User avatar
clem
Posts: 244
Joined: Tue Apr 01, 2008 2:17 pm
Location: Nova Scotia

Re: 87 Bronco II 2.9L Shuts off while driving

Post by clem » Sat Mar 20, 2010 5:41 pm

O.K can you pull codes? I would also check for spark after it dies. I would be looking at the coil very closely. I don't know how you clean a coil but you can check the resistance, even though when they heat up sometimes they fail. Please let us know if you figure this out. - Jeff
'87 bII d44,9",np435/205and a 302 ( on hold)
'73 vw bug
'70 vw camper van
'98 jeep tj
2010 ranger
'56 international s110

rlee728
Posts: 2
Joined: Sat Mar 20, 2010 1:26 pm
Location: Kansas City, MO

Re: 87 Bronco II 2.9L Shuts off while driving

Post by rlee728 » Mon Mar 22, 2010 5:00 pm

So, after replacing the Distributor Module, the Distributor, the Coil, checking every wire possible...went back to the coil and found out the pigtail on the coil wire from the distributor was bad. I know, should have been one of the first things I checked but hey, we found it. So keep that in mind if you run across the same thing. Thanks for the advice!!

User avatar
clem
Posts: 244
Joined: Tue Apr 01, 2008 2:17 pm
Location: Nova Scotia

Re: 87 Bronco II 2.9L Shuts off while driving

Post by clem » Mon Mar 22, 2010 5:22 pm

Glad you got it sorted.
'87 bII d44,9",np435/205and a 302 ( on hold)
'73 vw bug
'70 vw camper van
'98 jeep tj
2010 ranger
'56 international s110

Post Reply