2.8 getting no fuel?

Ask technical questions about your Ford Bronco II here. Technical write-ups on your axle swaps, engine swaps, chop tops, etc. are encouraged.
neb_scot
Posts: 60
Joined: Mon Nov 10, 2008 6:57 am

Re: 2.8 getting no fuel?

Postby neb_scot » Thu Aug 13, 2009 8:07 pm

I think its meant to be blue, but I could be wrong. At least its big.

At this point I usually place a screw driver with a well insulated handle into the spark leads and watch the spark through that too - to check that the quality is not being diminished by the plug. But given that you have already changed the plugs, I figure that wont make a difference.

For what its worth, my '84 B2 need all the electrics replaced on it when I got it - the previous owner had driven this thing into the ground so I know how you feel. I had the plugs, leads, rotor arm and coil replaced. I then had the idle changed. In an effort to overcome the poor electrics, some and some point had cranked up the idle speed. This in turn caused the carb to get real clogged and dirty......

Have you check to see if it has been 'firing' through the carb at all? as well as the exhaust.

Either way, I would check the rotor arm (my memory is they can break a lot) and the coil (or whatever its called) that provides the charge for the spark etc.

Again, Im only a beginner at this stuff - so I may be talking crap. Either way, the guys here have an astounding knowledge of the details of the B2 :beer:
1984 Ford Bronco II
2.8 v6 Engine
Manual Shift 5 speed
4 inch suspension lift

broncojeremy
Posts: 34
Joined: Fri Jul 31, 2009 3:50 pm

Re: 2.8 getting no fuel?

Postby broncojeremy » Fri Aug 14, 2009 6:57 pm

well i got a neww starter today and the motors turning i foundall kindsof wires and vaccum hoses chewed up by rats and patched em up wile i had nothing else to work with so im getting apickup fr the distributor tommorow and hopefully it works if not im dwn to a new distributor i'll be getting some pics up when i cn get it dirty itsnot verry photgenic and it's kindof a storage unit right now

User avatar
Ranger Dave
Posts: 1428
Joined: Sun Oct 10, 2004 5:53 am
Location: Newbury NH
Contact:

Re: 2.8 getting no fuel?

Postby Ranger Dave » Fri Aug 14, 2009 7:00 pm

broncojeremy wrote:yeah i hadit running pretty well
http://rangerdave.freeforums.org

broncojeremy
Posts: 34
Joined: Fri Jul 31, 2009 3:50 pm

Re: 2.8 getting no fuel?

Postby broncojeremy » Fri Aug 14, 2009 9:54 pm

well it was but aparrently water does no good unless it's in a radiator

broncojeremy
Posts: 34
Joined: Fri Jul 31, 2009 3:50 pm

Re: 2.8 getting no fuel?

Postby broncojeremy » Sat Aug 15, 2009 10:45 am

I FOUND OUT TODAY THAT THE DISTRIBUTOR IS THE SAME OUT OF A 3.0 WHCH I HAVE SITTING AROUND SO THAT SVS M 100$$$$$$$$$$$ ANDHOPEFULLY SOLVES MY PROBLEM

User avatar
Ranger Dave
Posts: 1428
Joined: Sun Oct 10, 2004 5:53 am
Location: Newbury NH
Contact:

Re: 2.8 getting no fuel?

Postby Ranger Dave » Sat Aug 15, 2009 10:59 am

NOT!!! they dont even look the same,plus there two different ing. systems. who ever told you that.have them show ya there the same


why do you need a dist.????? it was running "pretty well" so you say
http://rangerdave.freeforums.org

broncojeremy
Posts: 34
Joined: Fri Jul 31, 2009 3:50 pm

Re: 2.8 getting no fuel?

Postby broncojeremy » Sat Aug 15, 2009 12:24 pm

untili gt water all under thehood

broncofan
Posts: 68
Joined: Tue Aug 18, 2009 1:12 pm
Location: FT. Hood, TX.

Re: 2.8 getting no fuel?

Postby broncofan » Tue Aug 18, 2009 6:26 pm

did you make sure there was nothing on the top of the dist cap before you put it back on?
no crap on the metal inside the cap. plug wires on the right cylinders. change the filter in front of carb? check fuel then too. have someone turn engine over with line off fuel filter.
2013 Taurus SHO LMS V11 tune, 06 F150 Harley-Davidson Edition,03 Mustang GT Conv, 97 Jeep GC Laredo 5.2, 84 BII

broncojeremy
Posts: 34
Joined: Fri Jul 31, 2009 3:50 pm

Re: 2.8 getting no fuel?

Postby broncojeremy » Thu Aug 20, 2009 4:59 pm

new fuel filter pretty convinced it's the pic up coil but im just gonna get a new distributori think cause there are a few nicks on the gear

broncojeremy
Posts: 34
Joined: Fri Jul 31, 2009 3:50 pm

Re: 2.8 getting no fuel?

Postby broncojeremy » Fri Aug 28, 2009 9:45 pm

so it was thepick up coil in te distributor i replaced it andi drove it around the block and iwas backig up in front of my house andthe damn welded on harmonic balencer fell off agai i found a nother motor from a junk yard for $400 pricy but te only one. i'll buy it assuming i dont go to jail ths tuesday hopefully not because it'll be for 6months i'll miss the good weather, my favorite season and pssibly my babyboy being born. hope my luck don't run out :confused: :eek: :eek: :D :finger: :rolleyes: :rolleyes2: :beer: :beer: :beer: :beer: :beer: [youtube][/youtube]


Return to “Bronco Tech”

Who is online

Users browsing this forum: No registered users and 1 guest