Search found 71 matches

by broncofan
Fri Jan 14, 2011 6:44 pm
Forum: Bronco Tech
Topic: Starting issue
Replies: 1
Views: 354

Re: Starting issue

not to sure about your starting issue, but brake fliud goes in your clutch resovior
by broncofan
Fri Jan 14, 2011 6:40 pm
Forum: Bronco Tech
Topic: Bad clutch?
Replies: 11
Views: 757

Re: Bad clutch?

Not to sound stupid, but did you check your clutch master cylinder level. Make sure theres no leaks in it. do the easy things first
by broncofan
Mon Jan 10, 2011 2:06 pm
Forum: Bronco Tech
Topic: 2" lift questions...
Replies: 7
Views: 850

Re: 2" lift questions...

I put 31's on my 84 BII still needed a 3 inch body lift to clear so front wouldnt rub when turning
by broncofan
Mon Sep 27, 2010 1:50 pm
Forum: Bronco Tech
Topic: 2.8 cologne motor from 76 capri
Replies: 0
Views: 832

2.8 cologne motor from 76 capri

ok guys will the 2.8 out of a 76 capri match up to the tranny from my 84 bronco II . it has the 2.8 in it now, with the 4 speed tranny. The capri is carb , running and a five speed. No computer stuff at all. already has dura spark ignition. I also heard it has more torgue and horse power than the br...
by broncofan
Sat May 08, 2010 5:40 am
Forum: Bronco Tech
Topic: need help clutch
Replies: 4
Views: 470

Re: need help clutch

to the first guy, have you tried LMC truck. they have lots of Bii parts. the second guy are you checking to see if the clutch fork is engaging, remove the slave cylinder from the bell housing if you have to and have someone depress the clutch pedal if the rod moves its prob internal. if its moving s...
by broncofan
Sun Apr 11, 2010 6:53 am
Forum: Forum Help, Feedback and Info
Topic: upload avatar
Replies: 2
Views: 2547

upload avatar

imusing photobucket and i cant get the avatar to copy, it keeps telling me the url is invalid.any ideas?
by broncofan
Sat Apr 03, 2010 4:45 am
Forum: Bronco Tech
Topic: No Spark I think
Replies: 6
Views: 652

Re: No Spark I think

Glad you got her running again. Sorry about the tfi tool, i should have told you a allen wrench works just as well. As far as the wire just trace it and see where its from. my 84 doesnt have it. if you dont need it unhook it and mark it.
by broncofan
Tue Mar 30, 2010 6:00 pm
Forum: Bronco Tech
Topic: valves adjusted on 2.9l
Replies: 1
Views: 313

Re: valves adjusted on 2.9l

not hard to do at all. i'd check it out while its still in the other truck. start it, listen for the valve taps, make sure thats all it really needs. check the mileage and wear and tear.
by broncofan
Tue Mar 30, 2010 5:52 pm
Forum: Bronco Tech
Topic: No Spark I think
Replies: 6
Views: 652

Re: No Spark I think

does your bronco have the module on the back of the distributor? autozone can check it for you at no charge. Had to change mine twice since Ive owned my 84.
by broncofan
Sun Mar 14, 2010 6:49 am
Forum: Bronco Tech
Topic: Need new carb.
Replies: 6
Views: 677

Re: Need new carb.

if no motor or exhaust upgrade i'd stay stock. have you priced them ? 3 to 4 hundred easily, i'd rebuild.cost me 2 to have mine done some place in fla. took 1 week and lifetime gaurantee.
by broncofan
Sun Mar 14, 2010 6:44 am
Forum: Bronco Tech
Topic: Lots of smoking :/
Replies: 12
Views: 1085

Re: Hello again folks.. new water pump and thermostat on, still.

didnt really understand your post. picture of motor on stand? if all else fails drive the t-bird.
by broncofan
Sun Feb 28, 2010 6:11 am
Forum: Bronco Tech
Topic: My '84 Bronco ii is dead.. overheating help.
Replies: 9
Views: 1148

Re: My '84 Bronco ii is dead.. overheating help.

did you check the water pump, any noise coming from it? theres a weep hole under the water pump if they go bad it leaks from there can you start it with the radiator cap off add water and see if the coolant moves while running if it does its probably not your water pump. if its not that you may have...
by broncofan
Sun Feb 28, 2010 6:01 am
Forum: Bronco Tech
Topic: Valve cover seals?
Replies: 3
Views: 355

Re: Valve cover seals?

be careful tightening them down too, they snap easy, ive done it. i replaced mine it took about an hour, just clean them up real good too, all mating surfaces.
by broncofan
Sun Feb 28, 2010 5:57 am
Forum: Bronco Tech
Topic: help please
Replies: 12
Views: 689

Re: help please

my 84 is the same, but i have a red terminal wire with a fuseable link in it also I,ll look and see if i see where it goes. youve never said if it fires up and runs too.
by broncofan
Tue Feb 02, 2010 5:20 pm
Forum: Bronco Tech
Topic: 84 Bronco Ignition problem
Replies: 4
Views: 513

Re: 84 Bronco Ignition problem

does your accessories work with the switch on, radio, fan, wipers ? forward and backwards? if they do its not the switch.
check the grounds. do you get anything when you turn the key on? clicking, even if it starts by jumping the selonoid it still could be bad.check the easy stuff first.